Subject: How to get top and left position of top window
Posted by nineilson on Fri, 01 Apr 2011 20:57:48 GMT

View Forum Message <> Reply to Message

When debugging a watch set for "rect" gets this but | am not able to set a variable with this.
Same with Top and Left.

Get errors they are private/protected or whatever.

When a user moves the window to his preferred position | would like to save this to a config file.

Neil

Subject: Re: How to get top and left position of top window
Posted by dolik.rce on Sun, 03 Apr 2011 15:10:36 GMT

View Forum Message <> Reply to Message

nineilson wrote on Fri, 01 April 2011 22:57When debugging a watch set for "rect” gets this but |
am not able to set a variable with this.

Same with Top and Left.
Get errors they are private/protected or whatever.
When a user moves the window to his preferred position | would like to save this to a config file.

Neil
Hi Neil,

Do you mean GetRect()?
Also, if you are interested in storing window placement, you might want to look at
TopWindow::SerializePlacement(Stream& s,bool reminimize). It is aimed to binary serialization,

but even if you use some other form (cfg file, XML,...) it should give you some inspiration.

Best regards,
Honza

Subject: Re: How to get top and left position of top window
Posted by nineilson on Sun, 03 Apr 2011 16:14:44 GMT

View Forum Message <> Reply to Message

Hi Honza
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It took me about 6 hour tinkering to find something.
| had to do a a search with Windows file explorer for "rect" (not case sensitive) and search each
file with Notepad++ and finally found "GetRect().left;" and ended with this: int leftP =
GetRect().left;

int topP = GetRect().top;
Then it was a simple and straight forward implementation.

| have three computers | use to test with and all have a dual boot with Ubuntu so the Upp window
was in 6 slightly different positions. | don't release as finished something like that.

| don't know anything about "TopWindow::SerializePlacement".
When this is explained with a simple example in the Help docs | may try it.

Upp is a great project but there should be documentation for all of the functions/capabilities.
If it was not for the help on this forum, for someone like myself, Upp would not be a viable option.
Thanks

Neil

Subject: Re: How to get top and left position of top window
Posted by nineilson on Sun, 03 Apr 2011 17:29:02 GMT

View Forum Message <> Reply to Message

This is one of four Upp apps.

The first time it is run the Upp window can be moved to any position. Clicking File->"Save > Exit"
will save the window position (and ~10 other setting).

Neil

File Attachnents
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Subject: Re: How to get top and left position of top window
Posted by dolik.rce on Mon, 04 Apr 2011 16:29:11 GMT

View Forum Message <> Reply to Message

nineilson wrote on Sun, 03 April 2011 18:141 had to do a a search with Windows file explorer for
"rect" (not case sensitive) and search each file with Notepad++ and finally found "GetRect().left;"
and ended with this: int leftP = GetRect().left;

int topP = GetRect().top;
Then it was a simple and straight forward implementation.Why don't you use theide search
functions? E.g. Ctrl+Shift+F for search in files. Also, searching help or this webpage (via the

Page 2 of 7 ---- Generated from U++ franewor k


https://www.ultimatepp.org/forums/index.php?t=usrinfo&id=847
https://www.ultimatepp.org/forums/index.php?t=rview&th=5962&goto=31875#msg_31875
https://www.ultimatepp.org/forums/index.php?t=post&reply_to=31875
https://www.ultimatepp.org/forums/index.php?t=getfile&id=3158
https://www.ultimatepp.org/forums/index.php?t=usrinfo&id=647
https://www.ultimatepp.org/forums/index.php?t=rview&th=5962&goto=31886#msg_31886
https://www.ultimatepp.org/forums/index.php?t=post&reply_to=31886
https://www.ultimatepp.org/forums/index.php

google search box on the left, below menu) is a good idea. Reading Ctrl reference (which you
should read just after reading TopWindow reference, since TopWindow inherites from Ctrl) would
give you the answer in 15 minutes top.

nineilson wrote on Sun, 03 April 2011 18:141 have three computers | use to test with and all have
a dual boot with Ubuntu so the Upp window was in 6 slightly different positions. | don't release as
finished something like that.

| don't fully understand this... Do you mean that each computer and each OS gives different
placement? With default setting or with the position taken from the stored configuration? Also, why
do you think it is wrong? There is a lot of factors that influence this: window manager settings,
gnome/windows panel width, monitor size etc... If you wish to achieve the same position on all
systems (which is IMHO the least important part of design), you can use fixed window size and
call CenterScreen() method.

nineilson wrote on Sun, 03 April 2011 18:141 don't know anything about
"TopWindow::SerializePlacement”.

When this is explained with a simple example in the Help docs | may try it.It IS documented. The
description is in the first place where you should look for such function: in the TopWindow
reference. There is also an article on saving configuration and even more info can be found on the
forum. We all know that U++ documentation is not 100%, but this is not the case. TopWindow, Ctrl
and other parts of CtrICore are very well documented.

Honza

Subject: Re: How to get top and left position of top window
Posted by nineilson on Mon, 04 Apr 2011 20:30:05 GMT

View Forum Message <> Reply to Message

dolik.rce wrote on Mon, 04 April 2011 18:29

1. 1 don't fully understand this... Do you mean that each computer and each OS gives different
placement?

2. Why don't you use theide search functions? E.g. Ctrl+Shift+F for search in files. Also,
searching help or this webpage (via the google search box on the left, below menu) is a good
idea. Reading Ctrl reference (which you should read just after reading TopWindow reference,
since TopWindow inherites from Ctrl) would give you the answer in 15 minutes top.

3. 1t IS documented. The description is in the first place where you should look for such function:
in the TopWindow reference. There is also an article on saving configuration and even more info
can be found on the forum. We all know that U++ documentation is not 100%, but this is not the
case. TopWindow, Ctrl and other parts of CtrICore are very well documented.

Honza

1. Yes that is exactly what | mean, the Upp window is in different locations relative to my Java
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display app it interacts with for all 6. See the attached image. Now a user can drag the Upp app
window to wherever they prefer and with "Save > Exit" the Upp app will open in that location.

2. Ctrl+Shift+F, Ctrl+f or clicking Edit->Find and Replace->Find only searches the file in the
editor.
Also the only thing from debug was "rect".

Some of the time | don't have access to the web other than when | go into Mojave and hook up to
the wireless at McDonalds, much slower than my connection on Oxnard.

3. 1 will check out the documentation mentioned in 2. and 3..
Perhaps Documentation on how you get to the documentation as you mentioned in 2. and 3.
would be of help to Newbies like myself.

Thanks for the help Honza, that should save me time in the future.

Neil
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Subject: Re: How to get top and left position of top window
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Posted by nineilson on Mon, 04 Apr 2011 21:13:29 GMT

View Forum Message <> Reply to Message

dolik.rce wrote on Sun, 03 April 2011 17:10Do you mean GetRect()?

There are several threads on Upp/Python.
| am into Python, C/C++ (Upp) and Java so my head hurts sometime just keeping things straight.

One thing in Python is the Help is very good. Each function has a very simple example. Relating
this to what would be useful in Upp for this problem could be:
int leftPosition = GetRect.left;

Assist->Search word in Help Topics->"GetRect"

First a person needs to know to search for "GetRect" rather than "rect".
Then for the enum GetRect.left rather than trying rect[0] or ???

Upp is very good but sometimes it is hard to find how to solve what should a simple problem.

Neil

Subject: Re: How to get top and left position of top window
Posted by dolik.rce on Tue, 05 Apr 2011 17:10:08 GMT

View Forum Message <> Reply to Message

nineilson wrote on Mon, 04 April 2011 22:301. Yes that is exactly what | mean, the Upp window is
in different locations relative to my Java display app it interacts with for all 6. See the attached
image. Now a user can drag the Upp app window to wherever they prefer and with "Save > Exit"
the Upp app will open in that location.l would consider this minor issue, especially since you have
no guarantee that the Java window will always open at the same position... But anyway, if you
insist on this, just use LoadFromFile and StoreToFile at the beginning and end of your code,
respectively. Then override a Serialize method of your window with something like this:
void MyWindow::Serialize(Stream& s){

SerializePlacement(s); /I This stores/loads the window state and position

s % MyVariablel % MyVariable2; // Variables to be stored/loaded

s % MyVariable3;
}
This is just basic idea, you can find the details of the functions and concepts in the articles |
linked in one of the previous posts.

nineilson wrote on Mon, 04 April 2011 22:302. Ctrl+Shift+F, Ctrl+f or clicking Edit->Find and
Replace->Find only searches the file in the editor.
Also the only thing from debug was "rect".

Some of the time | don't have access to the web other than when | go into Mojave and hook up to
the wireless at McDonalds, much slower than my connection on Oxnard.Oops, | meant Ctrl+H,
sorry. All the important content from the webpage (excluding forum) is available within theide, so
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being off-line shouldn't be much of a problem...

nineilson wrote on Mon, 04 April 2011 22:303. | will check out the documentation mentioned in 2.
and 3..

Perhaps Documentation on how you get to the documentation as you mentioned in 2. and 3.
would be of help to Newbies like myself.Ctrl+F1 should search the word under cursor in the help. |
understand that searching for something like "rect" does show a lot of results (you can jump
between them using the green arrows next to the search box), most of them being useless. On
the other hand, the method GetRect() is a basic thing, mentioned in the tutorials and of course
also in the Ctrl reference (which everyone using U++ GUI should read, along with TopWindow
reference and few others...).

Honza

Subject: Re: How to get top and left position of top window
Posted by nineilson on Tue, 05 Apr 2011 19:21:23 GMT

View Forum Message <> Reply to Message

dolik.rce wrote on Tue, 05 April 2011 19:101. ... no guarantee that the Java window will always
open at the same position...

2. All the important content from the webpage (excluding forum) is available within theide, so
being off-line shouldn't be much of a problem...

3. (you can jump between them using the green arrows next to the search box)

4. the method GetRect() is a basic thing, mentioned in the tutorials and of course also in the Ctrl
reference (which everyone using U++ GUI should read, along with TopWindow reference and few
others...).

1. The Java window always opens in the top left corner. The different screen resolutions, the top
task bar in Linux, etc. is what causes the shift. | didn't like or want a user to drag anything when
the apps are started. Works fine now.

2. | noticed the help docs that are installed with Upp are very extensive now. That is a great help,
| just need to get familiar with using it. Before it was very limited.
This is a very big improvement for someone getting started with Upp.

3. The green arrows are very handy.

4. That has been my problem in not spending enough time understanding "Ctrl reference,
TopWindow reference and few others...". | just recently learned how to include bazaar in the
options to choose when opening thelde. C:\upp\examples\Bombs\main.cpp has "Rect r =
GetRect();" which didn't show how to get the left and top position. Other than that it is only found

in bazaar and uppsrc. This is looking back as previously | was looking for "rect".
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| appreciate the help, thanks Honza.

Neil
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